re = /((\D|^)0+(0|[1-9]+))/
str = '0127.00.09.01
107.000.09.01
107.0.70.01
107.9.0.01
23.107.000.09
107.09.0.01
23.0.107.000
23.0.107.00
23.0.0127.01'
subst = '$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result