#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((\D|^)0+(0|[1-9]+))"
Local $sString = "0127.00.09.01" & @CRLF & _
"107.000.09.01" & @CRLF & _
"107.0.70.01" & @CRLF & _
"107.9.0.01" & @CRLF & _
"23.107.000.09" & @CRLF & _
"107.09.0.01" & @CRLF & _
"23.0.107.000" & @CRLF & _
"23.0.107.00" & @CRLF & _
"23.0.0127.01"
Local $sSubst = "$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)