#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http:\/\/[a-z]+\.margonem\.pl\/"
Local $sString = "http://a.margonem.pl/" & @CRLF & _
"http://foo.margonem.pl/" & @CRLF & _
"http://hello-world.margonem.pl/" & @CRLF & _
"http://abcq443435u4531.margonem.pl/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")