import re
regex = re.compile(r"http:\/\/[a-z]+\.margonem\.pl\/", flags=re.MULTILINE)
test_str = ("http://a.margonem.pl/\n"
"http://foo.margonem.pl/\n"
"http://hello-world.margonem.pl/\n"
"http://abcq443435u4531.margonem.pl/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")