package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http:\/\/[a-z]+\.margonem\.pl\/`)
var str = `http://a.margonem.pl/
http://foo.margonem.pl/
http://hello-world.margonem.pl/
http://abcq443435u4531.margonem.pl/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}