$re = '/http:\/\/[a-z]+\.margonem\.pl\//m';
$str = 'http://a.margonem.pl/
http://foo.margonem.pl/
http://hello-world.margonem.pl/
http://abcq443435u4531.margonem.pl/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);