re = /http:\/\/[a-z]+\.margonem\.pl\//m
str = 'http://a.margonem.pl/
http://foo.margonem.pl/
http://hello-world.margonem.pl/
http://abcq443435u4531.margonem.pl/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end