import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/[a-z]+\\.margonem\\.pl\\/";
final String string = "http://a.margonem.pl/\n"
+ "http://foo.margonem.pl/\n"
+ "http://hello-world.margonem.pl/\n"
+ "http://abcq443435u4531.margonem.pl/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}