const regex = /http:\/\/[a-z]+\.margonem\.pl\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/[a-z]+\\.margonem\\.pl\\\/', 'gm')
const str = `http://a.margonem.pl/
http://foo.margonem.pl/
http://hello-world.margonem.pl/
http://abcq443435u4531.margonem.pl/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}