using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/[a-z]+\.margonem\.pl\/";
string input = @"http://a.margonem.pl/
http://foo.margonem.pl/
http://hello-world.margonem.pl/
http://abcq443435u4531.margonem.pl/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}