#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<Button.*className.*>"
Local $sString = "<Button text="black" className="bg"></Button>" & @CRLF & _
"<Button text='blue'></Button>" & @CRLF & _
"<Avatar className='clr' />" & @CRLF & _
"<Button text="black" className="bg"></Button>" & @CRLF & _
"<Avatar palette="primary" className="avatar"></Avatar>" & @CRLF & _
"<Button" & @CRLF & _
" text='white'" & @CRLF & _
" className="styles"" & @CRLF & _
">" & @CRLF & _
"</Button>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")