const regex = /<Button.*className.*>/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Button.*className.*>', 'mg')
const str = `<Button text="black" className="bg"></Button>
<Button text='blue'></Button>
<Avatar className='clr' />
<Button text="black" className="bg"></Button>
<Avatar palette="primary" className="avatar"></Avatar>
<Button
text='white'
className="styles"
>
</Button>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}