import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Button.*className.*>";
final String string = "<Button text=\"black\" className=\"bg\"></Button>\n"
+ "<Button text='blue'></Button>\n"
+ "<Avatar className='clr' />\n"
+ "<Button text=\"black\" className=\"bg\"></Button>\n"
+ "<Avatar palette=\"primary\" className=\"avatar\"></Avatar>\n"
+ "<Button\n"
+ " text='white'\n"
+ " className=\"styles\"\n"
+ ">\n"
+ "</Button>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}