import Foundation
let pattern = #"<Button.*className.*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<Button text="black" className="bg"></Button>
<Button text='blue'></Button>
<Avatar className='clr' />
<Button text="black" className="bg"></Button>
<Avatar palette="primary" className="avatar"></Avatar>
<Button
text='white'
className="styles"
>
</Button>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)