// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<Button.*className.*>").unwrap();
let string = "<Button text=\"black\" className=\"bg\"></Button>
<Button text='blue'></Button>
<Avatar className='clr' />
<Button text=\"black\" className=\"bg\"></Button>
<Avatar palette=\"primary\" className=\"avatar\"></Avatar>
<Button
text='white'
className=\"styles\"
>
</Button>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}