using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Button.*className.*>";
string input = @"<Button text=""black"" className=""bg""></Button>
<Button text='blue'></Button>
<Avatar className='clr' />
<Button text=""black"" className=""bg""></Button>
<Avatar palette=""primary"" className=""avatar""></Avatar>
<Button
text='white'
className=""styles""
>
</Button>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}