$re = '/<Button.*className.*>/m';
$str = '<Button text="black" className="bg"></Button>
<Button text=\'blue\'></Button>
<Avatar className=\'clr\' />
<Button text="black" className="bg"></Button>
<Avatar palette="primary" className="avatar"></Avatar>
<Button
text=\'white\'
className="styles"
>
</Button>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);