re = /<Button.*className.*>/m
str = '<Button text="black" className="bg"></Button>
<Button text=\'blue\'></Button>
<Avatar className=\'clr\' />
<Button text="black" className="bg"></Button>
<Avatar palette="primary" className="avatar"></Avatar>
<Button
text=\'white\'
className="styles"
>
</Button>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end