#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z0-9]{2,6}?\K(?=[0-9]{1,3}$)"
Local $sString = "T6" & @CRLF & _
"" & @CRLF & _
"T60" & @CRLF & _
"T601" & @CRLF & _
"T6010" & @CRLF & _
"T60109" & @CRLF & _
"T601092" & @CRLF & _
"T6010922" & @CRLF & _
"T60109222" & @CRLF & _
"" & @CRLF & _
"T601092222" & @CRLF & _
"T601092111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")