using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]{2,6}?\K(?=[0-9]{1,3}$)";
string input = @"T6
T60
T601
T6010
T60109
T601092
T6010922
T60109222
T601092222
T601092111111";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}