import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]{2,6}?\\K(?=[0-9]{1,3}$)";
final String string = "T6\n\n"
+ "T60\n"
+ "T601\n"
+ "T6010\n"
+ "T60109\n"
+ "T601092\n"
+ "T6010922\n"
+ "T60109222\n\n"
+ "T601092222\n"
+ "T601092111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}