$re = '/^[a-z0-9]{2,6}?\K(?=[0-9]{1,3}$)/mi';
$str = 'T6
T60
T601
T6010
T60109
T601092
T6010922
T60109222
T601092222
T601092111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);