import re
regex = re.compile(r"^[a-z0-9]{2,6}?\K(?=[0-9]{1,3}$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("T6\n\n"
"T60\n"
"T601\n"
"T6010\n"
"T60109\n"
"T601092\n"
"T6010922\n"
"T60109222\n\n"
"T601092222\n"
"T601092111111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")