const regex = /^[a-z0-9]{2,6}?\K(?=[0-9]{1,3}$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]{2,6}?\\K(?=[0-9]{1,3}$)', 'gmi')
const str = `T6
T60
T601
T6010
T60109
T601092
T6010922
T60109222
T601092222
T601092111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}