re = /^[a-z0-9]{2,6}?\K(?=[0-9]{1,3}$)/mi
str = 'T6
T60
T601
T6010
T60109
T601092
T6010922
T60109222
T601092222
T601092111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end