use strict;
my $str = 'T6
T60
T601
T6010
T60109
T601092
T6010922
T60109222
T601092222
T601092111111';
my $regex = qr/^[a-z0-9]{2,6}?\K(?=[0-9]{1,3}$)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}