# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(block-([0-9]+))\](.+?)\[\\/\1\]/<blockquote class="tm-style\2"><span>\n\3\n<\/span><\/blockquote>/gm;t' <<< "[block-2] \"Donec volutpat nibh sit amet libero ornare non laoreet arcu luctus. Donec id arcu quis mauris\". [/block-2]"