const regex = new RegExp('\\[(block-([0-9]+))\\](.+?)\\[\\/\\1\\]', 'gm')
const str = `[block-2] "Donec volutpat nibh sit amet libero ornare non laoreet arcu luctus. Donec id arcu quis mauris". [/block-2]`;
const subst = `<blockquote class="tm-style\2"><span>\n\3\n</span></blockquote>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);