#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[(block-([0-9]+))\](.+?)\[\/\1\]"
Local $sString = "[block-2] "Donec volutpat nibh sit amet libero ornare non laoreet arcu luctus. Donec id arcu quis mauris". [/block-2]"
Local $sSubst = "<blockquote class="tm-style\2"><span>\n\3\n</span></blockquote>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)