import re
regex = re.compile(r"\[(block-([0-9]+))\](.+?)\[\/\1\]", flags=re.MULTILINE)
test_str = "[block-2] \"Donec volutpat nibh sit amet libero ornare non laoreet arcu luctus. Donec id arcu quis mauris\". [/block-2]"
subst = "<blockquote class=\"tm-style\\2\"><span>\\n\\3\\n</span></blockquote>"
result = regex.sub(subst, test_str)
if result:
print(result)