use strict;
my $str = '[block-2] "Donec volutpat nibh sit amet libero ornare non laoreet arcu luctus. Donec id arcu quis mauris". [/block-2]';
my $regex = qr~\[(block-([0-9]+))\](.+?)\[\/\1\]~mp;
my $subst = '<blockquote class="tm-style\\2"><span>\\n\\3\\n</span></blockquote>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";