using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(block-([0-9]+))\](.+?)\[\/\1\]";
string substitution = @"<blockquote class=""tm-style\2""><span>\n\3\n</span></blockquote>";
string input = @"[block-2] ""Donec volutpat nibh sit amet libero ornare non laoreet arcu luctus. Donec id arcu quis mauris"". [/block-2]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}