#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".\/download\/file.php\?id=[0-9]{6}\&mode=view"
Local $sString = "<a href="./download/file.php?id=123456&mode=view"><img src="./download/file.php?id=123456&t=1"></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")