import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".\\/download\\/file.php\\?id=[0-9]{6}\\&mode=view";
final String string = "<a href=\"./download/file.php?id=123456&mode=view\"><img src=\"./download/file.php?id=123456&t=1\"></a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}