re = /.\/download\/file.php\?id=[0-9]{6}\&mode=view/
str = '<a href="./download/file.php?id=123456&mode=view"><img src="./download/file.php?id=123456&t=1"></a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end