// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".\/download\/file.php\?id=[0-9]{6}\&mode=view").unwrap();
let string = "<a href=\"./download/file.php?id=123456&mode=view\"><img src=\"./download/file.php?id=123456&t=1\"></a>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}