$re = '/.\/download\/file.php\?id=[0-9]{6}\&mode=view/';
$str = '<a href="./download/file.php?id=123456&mode=view"><img src="./download/file.php?id=123456&t=1"></a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);