package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.\/download\/file.php\?id=[0-9]{6}\&mode=view`)
var str = `<a href="./download/file.php?id=123456&mode=view"><img src="./download/file.php?id=123456&t=1"></a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}