const regex = /.\/download\/file.php\?id=[0-9]{6}\&mode=view/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.\\\/download\\\/file.php\\?id=[0-9]{6}\\&mode=view', '')
const str = `<a href="./download/file.php?id=123456&mode=view"><img src="./download/file.php?id=123456&t=1"></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}