#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|[^\d:])([0-5]?[0-9]:[0-5][0-9])([^\d:]|$)"
Local $sString = "23:45 Description blah 00:45 hey there 34:23 and then 1:00:45 0:00" & @CRLF & _
"and ignore 434:40:52" & @CRLF & _
"79:32" & @CRLF & _
"54:99" & @CRLF & _
"4:56"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")