// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|[^\d:])([0-5]?[0-9]:[0-5][0-9])([^\d:]|$)").unwrap();
let string = "23:45 Description blah 00:45 hey there 34:23 and then 1:00:45 0:00
and ignore 434:40:52
79:32
54:99
4:56";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}