import re
regex = re.compile(r"(^|[^\d:])([0-5]?[0-9]:[0-5][0-9])([^\d:]|$)", flags=re.MULTILINE)
test_str = ("23:45 Description blah 00:45 hey there 34:23 and then 1:00:45 0:00\n"
"and ignore 434:40:52\n"
"79:32\n"
"54:99\n"
"4:56")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")