import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^\\d:])([0-5]?[0-9]:[0-5][0-9])([^\\d:]|$)";
final String string = "23:45 Description blah 00:45 hey there 34:23 and then 1:00:45 0:00\n"
+ "and ignore 434:40:52\n"
+ "79:32\n"
+ "54:99\n"
+ "4:56";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}