package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[^\d:])([0-5]?[0-9]:[0-5][0-9])([^\d:]|$)`)
var str = `23:45 Description blah 00:45 hey there 34:23 and then 1:00:45 0:00
and ignore 434:40:52
79:32
54:99
4:56`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}