$re = '/(^|[^\d:])([0-5]?[0-9]:[0-5][0-9])([^\d:]|$)/m';
$str = '23:45 Description blah 00:45 hey there 34:23 and then 1:00:45 0:00
and ignore 434:40:52
79:32
54:99
4:56';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);