using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^\d:])([0-5]?[0-9]:[0-5][0-9])([^\d:]|$)";
string input = @"23:45 Description blah 00:45 hey there 34:23 and then 1:00:45 0:00
and ignore 434:40:52
79:32
54:99
4:56";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}