#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z](?:[a-zA-Z\.\s][^\n]*)[a-zA-Z]$"
Local $sString = " First name" & @CRLF & _
"First name " & @CRLF & _
"First name" & @CRLF & _
"8First name" & @CRLF & _
"First name8" & @CRLF & _
"First name last name" & @CRLF & _
"" & @CRLF & _
"Some.name with spaces"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")