import re
regex = re.compile(r"^[a-zA-Z](?:[a-zA-Z\.\s][^\n]*)[a-zA-Z]$", flags=re.MULTILINE)
test_str = (" First name\n"
"First name \n"
"First name\n"
"8First name\n"
"First name8\n"
"First name last name\n\n"
"Some.name with spaces")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")