$re = '/^[a-zA-Z](?:[a-zA-Z\.\s][^\n]*)[a-zA-Z]$/m';
$str = ' First name
First name
First name
8First name
First name8
First name last name
Some.name with spaces';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);