import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z](?:[a-zA-Z\\.\\s][^\\n]*)[a-zA-Z]$";
final String string = " First name\n"
+ "First name \n"
+ "First name\n"
+ "8First name\n"
+ "First name8\n"
+ "First name last name\n\n"
+ "Some.name with spaces";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}